Migrace z php 5.6 rubrika: Programování: PHP

8 havejir
položil/-a 27.9. 17:25

Dostal se mi do ruky velmi strarý projekt napsaný ještě v php 5.6 a vzhledem k tomu, že již končí podpora php 5.6. Je nezbyné tento projekt převést na novější verzi php. Jak se k tomuto problému mám postavit, abych nestrávil zbytek života přpisováním?

odkaz Vyřešeno
15 Taco
odpověděl/-a 27.9. 22:01
 
upravil/-a 27.9. 22:02

Začal bych tím, že bych to zkusil. V dockeru si pustit 7.2ku, a zkouknout co to řve. Samozřejmě testy jak píše Kit hodně pomůžou, ale známe se.

Dobrej pomocník, ale nikoliv všemocný je sstalle/php7cc, který by ti mohl vyhledat většinu nekompatabilit.

Můžeš zkusit i jen obyčejný php lint.

abych nestrávil zbytek života přpisováním?
Není to tak hrozné, odvahu! :-)

Pro zobrazení všech 7 odpovědí se prosím přihlaste:

Rychlé přihlášení přes sociální sítě:

Nebo se přihlaste jménem a heslem:

Zadejte prosím svou e-mailovou adresu.
Zadejte své heslo.